欢迎光临
我们一直在努力

【漏洞预警】Drupal内核远程代码执行高危漏洞及解决方案

推广者专属福利,新客户无门槛领取总价值高达2775元代金券,每种代金券限量500张,先到先得。

Drupal是使用PHP语言编写的开源内容管理框架(CMF),它由内容管理系统(CMS)和PHP开发框架(Framework)共同构成。连续多年荣获全球最佳CMS大奖,是基于PHP语言最著名的WEB应用程序。截止2011年底,共有13,802位WEB专家参加了Drupal的开发工作;228个国家使用181种语言的729,791位网站设计工作者使用Drupal。著名案例包括:联合国、美国白宫、美国商务部、纽约时报、华纳、迪斯尼、联邦快递、索尼、美国哈佛大学、Ubuntu等。

2019年1月17日,阿里云云盾应急响应中心监测到Drupal官方发布安全更新,披露了2个高危安全漏洞,攻击者利用漏洞,可能远程执行PHP任意代码获取服务器权限。

漏洞描述

Drupal在处理phar:// URI时未做安全处理,导致攻击者构造特定的请求触发Drupal代码(core,contrib和custom)中的文件相关操作时,可执行PHP反序列化导致远程代码执行漏洞。

漏洞评级

sa-core-2019-002 严重

sa-core-2019-001 严重

影响版本

Drupal 8.6.x < 8.6.6

Drupal 8.5.x < 8.5.9

Drupal 7.x < 7.62

安全版本

Drupal 8.6.6 及以上

Drupal 8.5.9 及以上

Drupal 7.62 及以上

安全建议

升级Drupal核心代码至安全版本

相关链接

https://www.drupal.org/security

赞(0) 打赏
未经允许不得转载:IT俱乐部 | 学习俱乐部 » 【漏洞预警】Drupal内核远程代码执行高危漏洞及解决方案
腾讯云国际顶级CA机构SSL证书8.8折,云解析买一年最高送半年!
腾讯云网站解决方案帮您轻松应对建站成本高/网络不稳等常见问题

评论 抢沙发

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址

免费分享阿里云&腾讯云优惠券,阿里云&腾讯云代金券领取,阿里云服务器ecs租用、阿里云服务器购买。领取本站阿里云优惠券可购买限时2折服务器,并返现20%费用。

阿里优惠直购腾讯优惠直购

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏